Users browsing this thread: 1 Guest(s)
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

MarkTWRP Samsung Galaxy S4 jfltecan | S4 SGH-1337M TWRP

So your trying to put TWRP recovery onto your Samsung Galaxy (S4 SGH-1337M) jfltecan (Canadian version). I'm glad you finally found this post while searching because following  hundreds of other websites is very nerve-raking and a complete waste of time. I've got very positive news that this is working 100% also just to tell you I have had the same problems as all of you and it went on for a year until i found the exact versions of software needed and that is what I'm sharing below.

Samsung Galaxy S4 Canadian owners, here is what you need to do  in order to put TWRP on this particular phone and model.

Requirements and steps:

First power off your Samsung phone, now press and hold  the Volume Down + Home + Power all at the same time until you see the Logo Samsung, right away let go of everything and press Volume Up and within a few seconds you should enter into Downloading mod.

1. Download Odin3 v3.10.0 (this version worked for me)

2. Download TWRP-3.1.1 = twrp-3.1.1-0-jfltecan.img.tar <--- (this version worked for me) NOT  twrp-3.1.1-0-jfltecan.img.tar.asc

Please watch this video and don't worry what model this guy is displaying or holding.... the same procedure works for all Samsung s4 phones.

If you interested in installing Android OS 9.0 PIE here is the link below

If you interested in installing Android OS  7.1 Nougat here is the link below

If you interested in installing Android OS   8.1.0 Oreo here is the link below

Thanks given by:

Who read this thread?
2 User(s) read this thread:
Admin (05-15-2019, 06:18 PM), Mark (05-16-2019, 02:20 AM)